Appendix D - Logging

Please note that these logs only show the beginning and ends of the logs, as they can be very large.

In WinPE, the typical log file to look in is the BITSACPSvc_<ContentId>.log file. This can be found in X:\Windows\temp\smstslog\

BITSACPStartup.log

Command-line arguments: BitsACP.exe X:\Windows\TEMP\SMSTSDownload.INI AP200003 C:\_SMSTaskSequence\Packages\AP200003

Checking to see if we are running in WinPE.

Initializing COM...

Created BITS COM Object.

Creating Download Job...

Writing BITS JobId Registry Key:{5ECDD140-041D-4138-A0AD-1D2569B094FB}

Successfully found a download Job from Registry...

We are running in WinPE or PreLogin Stage of OSD, will start Service.

Writing Registry Keys!

Writing PackageID Registry Key:AP200003

Writing ConfigFile Registry Key:X:\Windows\TEMP\SMSTSDownload.INI

Writing DownloadPath Registry Key:C:\_SMSTaskSequence\Packages\AP200003

Changing Log File Location to: X:\Windows\TEMP\smstslog\BITSACP_AP200003.log

BITSACP_<ContentId>.log

When in WinPE, this logs only tracks and shows the start of the BITSPE servce (BITSACP_ServiceMain.log and BITSACPService_<ContentId>.log progress, but when in full OS this log has the information for the actual download work.

The following is the start of a log in WinPE:

Releasing the Download job Pointer.

Checking is BITSPE Service is present on system.

OpenSCManager for:BITSPE

ERROR: OpenService failed:1060

Starting a new BITSPE Service instance.

Service installed successfully

Starting the Download Monitor Function.

Got _SMSTSNextInstructionPointer and _SMSTSInstructionTableSize from TS Env...

Registring UI

Successfully Registered UI

Calculating data size...

Progress UI Update returned errror code: 0

Initializing COM...

Getting BITS Job.

BITSACP_ServiceMain.log

This log typically only contains Service type information and can mostly be ignored:

ServiceMain: Entry

ServiceMain: Performing Service Start Operations

ServiceMain: Starting Worker Thread to complete

ServiceMain: Waiting for Worker Thread to complete

BITSACPSvc_<ContentId>.log

Getting the TS Environment port information

Setting the ports from TS Environment

Found advert ID, will use this for reporting: AP12008A

Cracking the URL...

Port: 443

Extra URL part:

Mode (HTTP=1, HTTPS=2): 2

URL is cracked, now putting back the pieces...

URL is HTTPS, setting the right authenticators and ports.

URL HTTPS port is set from TS Env: 443

Hostname:<server>.your.biz

Getting Download Job...

Successfully created Download Job...

Adding Description to the Download Job...

Connecting to server:

someserver.your.biz

443

Connecting with SSL: 1

Connecting with path: /NOCERT_SMS_DP_SMSPKG$/AP200003

Successfully set QueryInterface on Download Job...

Connecting to server...

Trying to connect...

Server replies with Status: 401

The server requires authentication. Sending searching credentials...